Device Details

Device Overview

Name/Version: Nord Lead 2X Remote 1.3
Author: Protonica  
Description: KEY FEATURES
--------------------------------------------------------------------------------------------------------------------
• Total recall: When you open your Live Project, all the saved values are automatically sent to your Nord Lead 2X hardware
• When you edit any knob from your Nord Lead 2X hardware, you can see it moving directly from the plugin
• View and edit all Morph/Velocity parameters
• Import & Export patches
• Easy access to the "Secret" filter type (Notch)
• Edit all sound parameters (bi-directional)
• Precise automation & modulation of all sound parameters
• Use up to 4 Layers for multi-sequencing or stacking (you have to load and route 4 instances to different MIDI tracks)
• Send patches from the plugin to your synthesizers edit buffer and save it from there (so the plug-in will not destroy your program bank by mistake)
• Randomize your patches to find inspirational sounds or mess it up ;) - just click the small circles in the headers (LFO, OSCs, Amp & Filter)
• Low CPU usage


SYSEX BRIDGE DOWNLOAD:
--------------------------------------------------------------------------------------------------------------------
http://www.protonica.de/piet/nordleadsysexbridge.zip


SETUP
--------------------------------------------------------------------------------------------------------------------
1) Download "Nord Lead 2X by Protonica.amxd" and copy it to: Ableton/User Library/Presets/MIDI Effects/Max MIDI Effect
2) Download and unzip "Nord Lead 2X SysEx Bridge.zip": http://www.protonica.de/piet/nordleadsysexbridge.zip and copy it to any location you like
3) Download and install Max Runtime (free) to be able to use the SysEx Bridge: http://cycling74.com/downloads/runtime
4) Open "Nord Lead 2X SysEx Bridge.maxpat" with Max Runtime and select the MIDI Ports your Nord Lead 2X hardware is connected to
5) Drag & Drop "Nord Lead 2X by Protonica.amxd" from Ableton's Browser (Max for Live -> Max MIDI Effect) on a new MIDI track in Ableton Live
6) Drag & Drop an "External Instrument" to the same MIDI track and set the MIDI and Audio routings according to your setup.
7) Open Ableton's Preferences and go to the MIDI/Sync Tab. Activate "Track" and "Remote" for both MIDI ports your Nord Lead is connected to (Input & Output). As an option you can activate "Sync" on your MIDI Port Output to be able to retrigger the LFO's in Sync with Live.
8) If you want to use the 4 Layers of the Nord Lead 2X create 4 MIDI tracks and repeat instructions 5) and 6)


SETTINGS ON YOUR NORD LEAD 2X HARDWARE
--------------------------------------------------------------------------------------------------------------------
• Connect 2 MIDI cables to the MIDI Input and MIDI Output from the Nord Lead to your Audio/MIDI Interface
• Global MIDI Channel: 16 (Press & Hold Shift + 2x "MIDI CH" Button = G.16)
• MIDI Channels of Layers (ABCD) must be the same as set in the "External Instruments" (e.g. A=1, B=2, C=3, D=4)
• Program Change: On (Press & Hold Shift + 1x "PROG.CTRL" Button = P.on)
• Control Change: On (Press & Hold Shift + 2x "PROG.CTRL" Button = C.on)
• Local Control: Off (to avoid glitches) (Press & Hold Shift + 1x "LOCAL" Button = off) -> this setting is not permanent after turning the power off!


DRIVERS (WINDOWS ONLY)
--------------------------------------------------------------------------------------------------------------------
• Please make sure to have dedicated drivers for your AUDIO/MIDI Interface installed. They should provide a so called "MULTIPLE CLIENT SUPPORT".


KNOWN BUGS
--------------------------------------------------------------------------------------------------------------------
• Problem: When you open a very large project in Ableton Live patches are occasionally not transferred correctly.
• Solution/Workaround: Close the project without saving (but keep Ableton running: load a new project) and open it again.


VERSION HISTORY
--------------------------------------------------------------------------------------------------------------------
1.1 New Nord Lead 2X GUI
1.2 Added Program/Bank Change incl. "Send" button to send all current controllers to the Nord Lead 2X
1.3 Major Update: Import/Export Patches (SysEx Dump), Layer, Velocity/Morph, Randomize, Mouse-over infos


REQUIREMENTS
--------------------------------------------------------------------------------------------------------------------
+ Clavia Nord Lead 2X or Clavia Nord Rack 2X
+ Ableton Live with Max for Live
+ Max Runtime (free): http://cycling74.com/downloads/runtime
+ Mac or PC


DONATION
--------------------------------------------------------------------------------------------------------------------
This device is free. If you'd like to reward me financially, that would be greatly appreciated. You can do so by making a donation via PayPal: https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=HT5TFZMT4NVWQ


Developed by Piet Kaempfer (Protonica)
 

Device Details

Downloads: 2614
Tags utility, hardware
Live Version Used: 9.0.4
Max Version Used: 6.1.2
Date Added: Sep 10 2013 09:31:32
Date Last Updated: Sep 01 2015 09:37:38
Average Rating (5) 5
Rate this device: (must be logged in to rate devices login)
Device Type: midi_device
URL (optional): http://www.protonica.de
License (more info): AttributionNonCommercialNoDerivatives

Device Files

Device File: Nord Lead 2X by Protonica.amxd
 


Comments

does this one work also with the Nord1 rack?

I don't have a Nord Lead 1 here to test. I guess most of the parameters should work with a Nord Lead/Rack 1 or 2 too (like Cutoff, Reso...). But when it comes to waveform selection, lfo destination etc. it can work different. Anyway i can easily make another device for Nord Lead 1 for sure, but would need a kind of bug report to see what i need to change.

It works.. awesome! Thanks for creating this.
Just missing a tab or something to scroll through the presets.

Now you are able to easily scroll through the bank and presets! Check Version 1.2 ;)

Fan of Protonica ! :)

@ Angelique http://www.facebook.com/protonica.de :)

any way you can make one for the nord lead 4?!?! @protonica I would love you forever

@ryancollins yes, as soon as i own one i will do it.

Hello protonica,

this is just amazing!!!
I have a nord lead 2 and I will test it as soon as I will eb home...ever had any chance of testing it yourself?

I will report back

thank you for sharing this!!!

Hello protonica,

this is just amazing!!!
I have a nord lead 2 and I will test it as soon as I will eb home...ever had any chance of testing it yourself?

I will report back

thank you for sharing this!!!

Hello protonica,

this is just amazing!!!
I have a nord lead 2 and I will test it as soon as I will eb home...ever had any chance of testing it yourself?

I will report back

thank you for sharing this!!!

Hello protonica,

this is just amazing!!!
I have a nord lead 2 and I will test it as soon as I will eb home...ever had any chance of testing it yourself?

I will report back

thank you for sharing this!!!

just stumbled across this, got my nordrack 2 out of its box, and rediscovered this beautiful synth! Works great!!! It's fantastically integrated in Live now.
I need some more time with it, to see how automation will work out, but for sound design it's perfect.

Something else I'll look into next time, is the preset browsing. You see, I have a PCMCIA memory card, which has quite some presets I'd like to audition again, and this setup won't allow me to browse to these banks. maybe disconnection a midi connection to the nordrack could solve this (temporarily, to get to the presets). I just made a percussion set, tried to save it to the memory card, but couldn't. As soon as you reach the last preset of the internal memory, you go back to 001. Luckily, saving the presets for the M4L device seems to work great, and probably has it's advantages.

So far, the only little thing is the preset handling on the M4L device itself. It seems you can only click through the presets instead of click/holding and scrolling through the list. Maybe I need to get more used to Push (which works fantastic with this editor, too), and the nordrack itself as well. So, not important at all for me...

Thanks a lot, Piet! Great stuff!!!

@borg thanks for your feedback!
you can scroll through the presets by moving the mouse (left click and hold) over the preset number field. Or type in the desired program number. If u have problems with the program up/down buttons you can try to use "Local on" mode on your synth. this m4l device is tested only for nord lead 2x (which don't uses pcmcia cards anymore)!

I would pay for a Lead 3 version of this! Any chance of developing one? Thanks!

Is this possible to convert this into a VST plug-in to use it in Cubase?

Cool, but... my reKon audio VST-AU Lead 2 Editor (http://rekonaudio.com) software already does all this, and it works in all the major VST/AU based DAW hosts out there. It also does not require M4L when used in Live. Yours only works with M4L and Live. Of course, yours is free though. So, that's a bonus for M4L + Lead 2x users I suppose, and it is kind of you to have shared your work.

Also, be prepared to deal with the Clavia Music litigation team for using the actual Nord Lead logo. I went through hell with Clavia just over the name of the editor (I originally named mine the VST Nord Lead Editor without using their logo) and they contacted me about it to change it. I also had similar issues with Access Music when I released the VST Virus Editor back in 2006. Be very careful that the graphics and names you use on your products are not already used or protected by copyright laws!

Cheers,
lanrosta

yes, i even bought the rekon lead editor first. but to be honest the handling for me was not as good as i thought. morphing, mouse behaviour, setup etc. thats why i build this m4l device for the lead2x.

yes, i even bought the rekon lead editor first. but to be honest the handling for me was not as good as i thought. morphing, mouse behaviour, setup etc. thats why i build this m4l device for the lead2x.

Hi
thanks very much for sharing this device!
I try to use it with my Nord Lead 2 on a Windows 7 64 PC and I can't seem to get the sysex transfer to work. If I select the MIDI devices in the Max sysex bridge patch I cannot use them in Live anymore and vice versa.
Do I have to use a MIDI loopback device or something to be able to dump sounds from and to my Nord?
Best regards and thanks again.
bassmatiker

bassmatiker, this is a strange behaviour. it must work with every midi interface (sysex and simple midi at the same time). make sure to connect both midi in and out. also check the midi i/o settings on the ableton preferences.

Thank you. I have already checked the settings multiple times, updated Max and so on, but still no luck. Can someone confirm the sysex dump functionality is working with Nord Lead 2 (not 2x) on a Windows 7 PC? Maybe the dump request commands differ slightly?
With another MIDI interface device I own (NI Komplete 6) the strange behaviour of exclusive availability of MIDI ports does not appear, so this does not seem to cause the problem.
The MIDI IN signal is received in the sysex bridge as well as in Live.
Is the MIDI Out Signal control in the sysex bridge supposed to flash when I move your controller's buttons? Because it does never ever flash.
Thanks very much.
bassmatiker

Hey Guys!

I'm sorry if this is a noob question.. but does this work like a VST-Plugin in Ableton? Can i drop audio effects and so on? Like i do with Sylenth etc? Sorry if this information is here somewhere, couldn't find it.

Best,
Olkan

Hey Guys!

I'm sorry if this is a noob question.. but does this work like a VST-Plugin in Ableton? Can i drop audio effects and so on? Like i do with Sylenth etc? Sorry if this information is here somewhere, couldn't find it.

Best,
Olkan

Hey Guys!

I'm sorry if this is a noob question.. but does this work like a VST-Plugin in Ableton? Can i drop audio effects and so on? Like i do with Sylenth etc? Sorry if this information is here somewhere, couldn't find it.

Best,
Olkan

Hi Piet

I am having the same issues as Bassmatiker with Nord Lead 2 keyboard, on Mac Ableton 9.1

SysEx bridge will see a signal in the MIDI input and flash but nothing on the MIDI output, so the SysEx dump in the max for live device does not work in either direction, it just changes all parameters to zero.

I would love to be able to get this to work so I an save patches in Live, any help appreciated!

Thanks

Hi Apeks,

The MIDI Output Signal from the SysEx Bridge must flash on every dump (Send & Get/Request) you make from the plug-in. Even if a NordLead is not connected.
I build this plug-in for a NordLead 2X which has some minor differences to the NordLead 2. Sending a patch from the Plugin to the NordLead 2 could work.
Receiving a patch from the NordLead 2 (Patch Dump Request) via the plugin could work maybe if you change a code in the plugin: Open the plugin in Max4Live, unfreeze it, go to Patch Mode, find the info box called "Patch Dump Request 14 (Edit Buffer) 0-3 (Slot A-D)", double click on "pack 240 51 15 4 14 0 247" and type in "pack 240 51 15 4 0 0 247", than save it and quit max4live and Ableton. (not sure if it works! just an idea because the MIDI Implementation in the manual from Clavia was incorrect in this case).

In general I only can give the advice to try the plugin with a NordLead 2X only.

Cheers
Piet

Hi Apeks,

The MIDI Output Signal from the SysEx Bridge must flash on every dump (Send & Get/Request) you make from the plug-in. Even if a NordLead is not connected.
I build this plug-in for a NordLead 2X which has some minor differences to the NordLead 2. Sending a patch from the Plugin to the NordLead 2 could work.
Receiving a patch from the NordLead 2 (Patch Dump Request) via the plugin could work maybe if you change a code in the plugin: Open the plugin in Max4Live, unfreeze it, go to Patch Mode, find the info box called "Patch Dump Request 14 (Edit Buffer) 0-3 (Slot A-D)", double click on "pack 240 51 15 4 14 0 247" and type in "pack 240 51 15 4 0 0 247", than save it and quit max4live and Ableton. (not sure if it works! just an idea because the MIDI Implementation in the manual from Clavia was incorrect in this case).

In general I only can give the advice to try the plugin with a NordLead 2X only.

Cheers
Piet

Thanks for getting back to me so quickly.

I've just had a breakthrough - i sent the dump from the actual keyboard rather than clicking the button on the max for live editor and it worked!

Thanks again for creating this device - its really helpful to see what some of the hidden parameters are and so useful for saving patches!

Hopefully this will work for anyone else with a Lead 2 rather than 2x

does it works with NL2?

A great device! Very well done.

Regarding the SysEx bridge "occupying" the MIDI device:
I can get it to work with my Scarlett 6i6, but not with the Elektron TM-1. Maybe there's a "multi-client" issue with the MIDI ports ?


Tempo syncing? How to sync arpeggiator, filter mods, etc with track tempo?

Tempo sync is not possible with a Nord Lead 2x. Only Key-retrigger which Clavia calls "Sync" which you can find at the "Special" menu on the hardware.

This device is AMAZING!!!! Awesome work! This device (with the SYSEX bridge) has never once given me a problem. Personally, I prefer sound designing on hardware synths (I'm so sick of looking at a Massive and Sylenth1 screen), but the added functionality with this is so useful that it can not be overstated. Thanks, Protonica

I'd also like to add that this and Overloud's ReMatrix (set up on Send A) are the only 2 devices I have set up for my Default Ableton template

simply genius

Hey guys!

I have to say, what an amazing device... works extremely smoothly.

I have just one issue and is when it comes to save the patch, is not working. When I save the patch and try to reopen it he returns to the default sound.

I'm running Windows 7 and when I open the nordlead SysEx Bridge it appears the "Microsoft windows synthetizer" but no matter what output I select he always returns to the "Microsoft synthetizer" output.

I don?t know what to do, I can?t bypass that midi out

Does anybody else have this issue?

thanks!

being that this is my 3rd comment on this page- I just wanted to add that you guys (Protonica) are awesome for not even charging for this amazing device

excuse me if I'm off topic... can I use this sysex bridge with other synthesizers? basically, I'm looking for a universal sysex bridge, or something like that... :)

it's not an universal sysex bridge to use with other synthesizers. but you can use the bridge to receive and send any sysex message. the received messages has to be translated and converted (in an dedicated plugin), which the remote plugin does - in this case for the nord lead 2x. theoriticaly there could be a plugin which receives, saves and sends sysex messages - but actually that shoud be the job of ableton to give us complete control over sysex.

hi! tnx for replying! I own several synths which have no dedicated plugins (Kawai, Ensoniq, Quasimidi), so I'm looking for some SysEx control... I understand that the bridge lets you at least pass SysEx to and from Ableton... I tried another bridge (http://www.maxforlive.com/library/device/2832/m4l-sysex) but it doesn't even see my midi ports...

hi! tnx for replying! I own several synths which have no dedicated plugins (Kawai, Ensoniq, Quasimidi), so I'm looking for some SysEx control... I understand that the bridge lets you at least pass SysEx to and from Ableton... I tried another bridge (http://www.maxforlive.com/library/device/2832/m4l-sysex) but it doesn't even see my midi ports...

Hello ,

Using Ableton 9 with Max 7 on PC with Win7.
VST bridge doesn't works when Ableton is running . When i start the bridge i get following error in MAX console :
midi_mme: error 1 opening midi input device FirePod #00C6091749 MIDI In
midi_mme: error 1 opening output device FirePod #00C6091749 MIDI Out

Looking like Ableton locks MIDI ports i want to use with Nord Lead.

Should i setup something in Ableton before using the bridge?
Do i need register\install the bridge ? I just double click on Nord Lead 2X SysEx Bridge.maxpat file to start it , is that correct way to run the bridge ?

Thanks!




Hello ,

Using Ableton 9 with Max 7 on PC with Win7.
VST bridge doesn't works when Ableton is running . When i start the bridge i get following error in MAX console :
midi_mme: error 1 opening midi input device FirePod #00C6091749 MIDI In
midi_mme: error 1 opening output device FirePod #00C6091749 MIDI Out

Looking like Ableton locks MIDI ports i want to use with Nord Lead.

Should i setup something in Ableton before using the bridge?
Do i need register\install the bridge ? I just double click on Nord Lead 2X SysEx Bridge.maxpat file to start it , is that correct way to run the bridge ?

Thanks!




@ztazz

Some MIDI interfaces/soundcards don't support MULTI CLIENTS on WINDOWS. Please check if you can get a dedicated driver for your interface or try other interfaces from RME, Motu, Steinberg etc.

Cheers
Piet

Hi,
very cool plugin, I love that.
Unfortunately I can't get it to work properly with mY Nord Lead 2. I can't import Sysex from the Synth to the plugin...

So I was wondering Can I open directly Sysex files? So I could dump sysex to pc then load them to the plugin...

thanks,

F.

I can confirm that this plugin works great with the Nord Lead 2x. I then tried it with my Nord Lead 2 and it wouldn't work properly.

Patch Dump Request:

"pack 240 51 15 4 14 0 247" - This worked but the filters or envelopes were tampered with and thus the patch did not sound identical. I presume this is because I'm using a NL2x request sysex string instead of an NL2.

So ...

I then edited the plugin and tried the following as instructed in the NL2 manual.

"pack 240 51 15 4 0 0 247"

This time no patch was dumped to the plugin at all. This means either the sysex string ( thus manual ) is incorrect OR there is another parameter that needs to be changed in the plugin.

In any event, I can at least confirm that the Nord Lead 2 DOES NOT work with this plugin. Only the 2x which was the developers original intention anyways. So all is fine.

Thanks very much for the excellent plugin.

Jim

By the way, the mutator or random function in this plugin alone is AWESOME! I am getting so many cool sounds and ideas now. I really like how you separated the mutator sections instead of changing all parameters which usually results in patches that are not musical. The plugin allows me to dial in better the exact areas I wish to mutate. I wish the Nord Lead 4 did this, although it does have five mutation degrees which is similar.

Thanks again.

Jim

Oh and one more thing! Are the layer slot letters suppose to change when I select them in Ableton? The patch numbers and most of the other parameters change on my NL2x, but I have to physically change the layer or slots on both the synth and Ableton. Not a problem, but thought I'd ask since it's not consistent with the rest of the plugin. Thanks. - Jim

Hello again. I didn't think to try Apeks method which he mentions as follows for the NL2.

"I've just had a breakthrough - i sent the dump from the actual keyboard rather than clicking the button on the max for live editor and it worked!"

That should do the trick instead of using the plugin to initiate the transfer. I'll give it a shot.

Thanks.

Hey thank you for this! I'm a prog psy trance dj from Argentina and being playing Protonica track since many years now. So, thanks for the music and this amazing M4L device.
ag0os (djNeurona)

Hi,

installed today and I have a question and a problem:

I have Max4Live 7.2.4 running, and I was not successful to run the sysex bridge without installing an older runtime (6.1). Before installing the older runtime I have tried without and got a message I should authorize M4L in Ableton by editing a device. Although I clicked on "edit" on the NL2xRemote Device, this has not changed.

I only get the bridge running by starting the runtime, loading the bridge and configuring in & out. In addition, I could not save this and need to do this every time. What am I doing wrong? Is it possible to set this up in a way without starting and configuring things before I run Ableton?

The problem I have is that I need to load a Live Set 2 times until the changed patches get transferred. Today I reboot the PC an switched everything off about 10x. Each time it is the same:

1. Start the runtime
2. Load sysex bridge
3. Configure midi
4. Start Ableton
5. Load Live Set - has the sounds from the NL
6. Load Live Set again - has the sounds from the live set

As so many people are happy with this Max device, it must be a mistake I am doing on my side. I have about a week left to decide if I will keep the NL2x or give it back. Having such a hick up when using it, will make it useless for me.

Hope anyone has any idea what I can do to get it running in a good way.

Kr,
robse

@robse

I guess you are doing it right (almost same procedure here). Ableton does not support SysEx natively so the Bridge is still a compromise solution and causes the majority of your inconvenience with the plugin. :/ Also please keep in mind that you are dealing with a (free) hardware/software solution which even on a Virus TI needs some 'tech love' to make it work nicely... If that's too much and useless you should go with synth plugins instead of hardware.

I usually do a double click on the maxpat file to open the bridge. It's not possible to save the settings, because the sysex bridge will update the available Midi ports on every load. When you open a big live project it can sometimes happen, that the data is not fully sent to the NL on the first load (there are some 'timers' inside the plugin which could cause this problem). So I recommended already in the description to reload the project - 'known bugs'.

Cheers
Piet/Protonica

@Piet

Thanks a Million for your fast reply! Double clicking on the maxpat files is something I can perfectly live with for sure.

But now I have tried a second time and still don't get it running with "total recall".

I have opened a project with 3 tracks only:

1. Drum Rack
2. nl2x remote out to midi channel 1 / activated slot A
3. nl2x remote out to midi channel 2 / activated slot B

On the Nordlead 2X I have set "globally" that Slot A is on Midi channel 1, Slot B on 2, Slot C on 3 and Slot D on 4 - global Midi channel 16

The 4 Mono outputs are connected to the 4 slots, like I was playing 4 non stereo synths. This way I can use Push2 perfectly with the Mixer for instance.

I have also changed Performance A1 to have the same settings for Midi & Audio and then I tested with both: Perfomance Mode on & Performance Mode off.

In the beginning I changed sound, played a bit and saved. Opened another project, changed NL2x sounds and went back to the test project.

What happened then was random: One sound was there, the other one was not the one I have created before. Then a second time: No sound changes were stored. As I said, I did that with Performance Mode on & off.

I noticed that sometimes I was not able to switch a button on the NL2x at all. Then I played around in the editor and it worked again. This looks like the Midi message did not get handled correctly.

If you see something I am doing wrong or if you have any advice how to set up correctly (4 synths on 4 outs, no layering), that would be great. Maybe I should try other Midi cables too.

BTW, I noticed that this is for free and still it is the only one with the perfect concept for Ableton & Push! I really hope I get it running, because it would just be great!

Br,
robse

@Piet

Thanks a Million for your fast reply! Double clicking on the maxpat files is something I can perfectly live with for sure.

But now I have tried a second time and still don't get it running with "total recall".

I have opened a project with 3 tracks only:

1. Drum Rack
2. nl2x remote out to midi channel 1 / activated slot A
3. nl2x remote out to midi channel 2 / activated slot B

On the Nordlead 2X I have set "globally" that Slot A is on Midi channel 1, Slot B on 2, Slot C on 3 and Slot D on 4 - global Midi channel 16

The 4 Mono outputs are connected to the 4 slots, like I was playing 4 non stereo synths. This way I can use Push2 perfectly with the Mixer for instance.

I have also changed Performance A1 to have the same settings for Midi & Audio and then I tested with both: Perfomance Mode on & Performance Mode off.

In the beginning I changed sound, played a bit and saved. Opened another project, changed NL2x sounds and went back to the test project.

What happened then was random: One sound was there, the other one was not the one I have created before. Then a second time: No sound changes were stored. As I said, I did that with Performance Mode on & off.

I noticed that sometimes I was not able to switch a button on the NL2x at all. Then I played around in the editor and it worked again. This looks like the Midi message did not get handled correctly.

If you see something I am doing wrong or if you have any advice how to set up correctly (4 synths on 4 outs, no layering), that would be great. Maybe I should try other Midi cables too.

BTW, I noticed that this is for free and still it is the only one with the perfect concept for Ableton & Push! I really hope I get it running, because it would just be great!

Br,
robse

@robse

The remote plugin does not support Performance Mode! You need to stay in Program/Patch Mode.

Here is what I do to make use of the 4 Layers (A,B,C,D) on 4 different Channels/MIDI Tracks (please read careful):

1. Create 4 MIDI Tracks
2. put on each MIDI Track the remote plugin and an 'External Instrument'

? Settings on all MIDI Tracks:
'MIDI From': All Ins / All Channels - I own the Rack Version of NL2X, so another MIDI Keyboard will send notes, Pitch Wheel and ModWheel data to it
?Monitor': Auto
?Audio To? Master

? Settings on the plugins:
MIDI Track 1 = Program Slot/Layer A
MIDI Track 2 = Program Slot/Layer B
MIDI Track 3 = Program Slot/Layer C
MIDI Track 4 = Program Slot/Layer D

? Settings on 'External Instruments':
MIDI Track 1 = 'MIDI to: Ch.1' - 'Audio from: 1' - ?Latency: 2ms'
MIDI Track 2 = 'MIDI to: Ch.2' - 'Audio from: 2' - ?Latency: 2ms'
MIDI Track 3 = 'MIDI to: Ch.3' - 'Audio from: 3' - ?Latency: 2ms'
MIDI Track 4 = 'MIDI to: Ch.4' - 'Audio from: 4' - ?Latency: 2ms'

? Settings on the NL2X hardware:
Layer A = MIDI CH 1
Layer B = MIDI CH 2
Layer C = MIDI CH 3
Layer D = MIDI CH 4
Global MIDI CH = G.16
Local = off

Now comes the 'tricky' part: everytime you want to control or change a certain Layer you have to
1) press the Program Slot/Layer on your NL2X Hardware (A,B,C or D)
2) press the TRACK ARM BUTTON in Ableton of the MIDI Track which you want to change (if Layer A, click the Track Arm Button of MIDI Track 1)


If you did everything correctly you are able to play 4 different MIDI clips at the same time, send & receive SysEx for each Layer, make Velocity/Morph settings for each layer, automate/modulate different layers etc. And most important: total recall!


Hope it helps
Cheers
Piet/Protonica

and one more thing:

? Settings on the NL2X hardware:
OUT MODE: 4.Ab and 4.cd (or -.cd)

Hello Piet,

much appreciated! Thank you for the detailed explanation. I have set up everything again and it is still not working (Total Recall).

I think it is a problem with the Sysex, either the NL2X is buggy or the Steinberg UR 22 Interface causes the issue or something is wrong with M4L.

I watched the Sysex Out LED in the bridge, it flashes a splitsecond when reopening the project and sounds are random. Either nothing is changed but a program change is done, or it changes parts of the sound only, not all parameters.

I think I have to investigate at another place (Midi Sysex in Ableton, Midi & Steinberg and the Synthesizer itself).

As I have only a few days left to decide if I give the NL2X back, it may happen that I will continue using VSTs only. This would be a bit sad, as the NL2X is awesome sounding compared to the Discover DSP, which I own and which is still good. The good news would be, that I will save a lot of money not buying the NL2X and a new Steinberg Interface with 4 Ins.

I would like to say that your Max Device is awesome. It is the perfect integration into Ableton and no matter if I will use it or not, many thanks for this great gift you give to other musicians!

Best wishes,
robse




@robse

Here is a small checklist of problems which users often have while setting up:
- Are you using Windows? If so, I highly recommend to download drivers for the ur22 with a so called "Multi Client" support.
- Does the plugin send all data in a small project of 1-4 channels only (total recall)?
- Are you able to make changes of the Morph/Velocity layer?
- Have you followed the setup instructions correctly? (e.g. Ableton's Midi Preferences tab)

@robse

Here is a small checklist of problems which users often have while setting up:
- Are you using Windows? If so, I highly recommend to download drivers for the ur22 with a so called "Multi Client" support.
- Does the plugin send all data in a small project of 1-4 channels only (total recall)?
- Are you able to make changes of the Morph/Velocity layer?
- Have you followed the setup instructions correctly? (e.g. Ableton's Midi Preferences tab)

Login to comment on this device.

[ browse device library ]