Device Details

Device Overview

Name/Version: MultiMapperCC 1.1.2
Author: mothergarage  
Description: Adapted my MultiMapper device to use it with continous control messages and external instruments. Part of the code is from "External Instrument MIDI Control" by prodavid.

Version 1.01: Minor GUI changes.

Version 1.02: Fixed automapping index.

Version 1.1: Added "speedlim" to the patch (thanks tripngroove), this might be a dirty fix, please comment for better solutions & Added a toggle to deactivate automation of dials.

Version 1.1.1: Bugfixes

Version 1.1.2: Bugfixes
 

Device Details

Downloads: 1542
Tags utility
Live Version Used: 9.0.6
Max Version Used: 6.1.4
Date Added: Jul 11 2013 10:38:23
Date Last Updated: Oct 24 2013 14:05:18
Average Rating -n/a-
Rate this device: (must be logged in to rate devices login)
Device Type: midi_device
URL (optional): http://www.mothergarage.at/
License (more info): None

Device Files

Device File: MultiMapperCC.amxd
 


Comments

Hello! Thank you very much for your device, it?s very useful. The only thing that doesn?t work is that, at least in Live 9.0.5/Max 6.1.3, it doesn?t recall the names you enter with the rename buttons. This is annoying because it?s really useful to have the parameters names at view. If you could fix it, it would be wonderful. Thanks in advance.

One more thing : I meant that when you close the project, the next time you open it, the names have dissapeared and you only see the default numbers. Just in case I didn?t explain it well...

Thanks for this. Great work. I have one suggestion / request.

When I rack this up and save it to my browser. It doesnt save the cc#'s assignments with it. So, when I drag it in from the browser all the cc# assignments have to be re-made.

Is there any way to make it save the cc# assignments when I save a rack to Live's browser?

@SDG:

This seems to be a problem with max4live. I could try to layer a textbox over the dial text. In the meantime you could rack the device and map the dials to macro knobs.

@rishi:

Seems to work fine here?!

Thanks for the quick reply. Racked or Unracked all the cc's revert to zero when dragged from the browser.

Interestingly I can see just briefly when it loads the cc numbers are there and then they all switch to zero.

I am on a Mac with Live 9.06

When I create automation lanes for more than one CC, I get massive tempo slowdown... any thoughts on fixing this? Maybe I should mod this to *speedlim* the throughput?

Thanks!

Adding speedlim to the patch fix my problem. Probably a better way to do it, but here it is anyway: http://pastebin.com/wR8K7JQc

Thanks tripngroove, I'll include this in the next update!

Very useful tool!

Very useful tool!

Great Device! Especially since it saves Mapping really well in complex sets even if you change the order of devices and stuff. Some other mapping devices get confused there for some reason.

But how about giving it some Curving abilities?

Mapulator doesn't work anymore and the author seems to be vanished. I'd be looking forward to get some basic preset curving features.

Also you cannot map the device to other Multimappers. That could be another feature request.

Login to comment on this device.

[ browse device library ]