User Details

Username: Protonica
Website: www.protonica.de
Facebook: www.facebook.com/protonica.de
Twitter: twitter.com/protonicade
Soundcloud: www.soundcloud.com/protonica
Account Status: enabled
Member since: Sep 10 2013
About Protonica:
(report this profile)

Devices by Protonica

Nord Lead 2X Remote Version 1.3
TB-3 Remote Version 1.11
Bass Station 2 Remote Version 1.0

Total Downloads: 9,187


Comments by Protonica

Comments

@Somecallmefamous
I'm not forcing anybody. I'm sharing my private work, where i put endless hours of work in it. I can keep it just for me. But if somebody wants to use it aswell, is it too much asked for a litte compensation? Seriously... wtf

@ Arunarush

yes an Update is in the making!

@biffish @maky357
Ok, thanks for the infos. When I have time I can try to remove the SysEx Bridge and include SysEx communication to the plug-in. The plugin might not be free of charge after the update.

Hello Ivo,

I assume it's a MIDI Buffer overload.
This can happen when you have heavy automations going on (e.g. sending over 6 automations simultaneously).
I recommend to check and delete the recorded automations in the MIDI Clips (check Envelopes -> MIDI Controllers) as well. Usually Ableton records doubled: automations in the arrangement and to a single MIDI Clip. That's why your arrangement automations could get greyed out.

Hope it helps
Piet

true, i've changed it. thanks for the advice

Robert Bondi, Have you checked your email spam folder?

@robse

Here is a small checklist of problems which users often have while setting up:
- Are you using Windows? If so, I highly recommend to download drivers for the ur22 with a so called "Multi Client" support.
- Does the plugin send all data in a small project of 1-4 channels only (total recall)?
- Are you able to make changes of the Morph/Velocity layer?
- Have you followed the setup instructions correctly? (e.g. Ableton's Midi Preferences tab)

@robse

Here is a small checklist of problems which users often have while setting up:
- Are you using Windows? If so, I highly recommend to download drivers for the ur22 with a so called "Multi Client" support.
- Does the plugin send all data in a small project of 1-4 channels only (total recall)?
- Are you able to make changes of the Morph/Velocity layer?
- Have you followed the setup instructions correctly? (e.g. Ableton's Midi Preferences tab)

and one more thing:

? Settings on the NL2X hardware:
OUT MODE: 4.Ab and 4.cd (or -.cd)

@robse

The remote plugin does not support Performance Mode! You need to stay in Program/Patch Mode.

Here is what I do to make use of the 4 Layers (A,B,C,D) on 4 different Channels/MIDI Tracks (please read careful):

1. Create 4 MIDI Tracks
2. put on each MIDI Track the remote plugin and an 'External Instrument'

• Settings on all MIDI Tracks:
'MIDI From': All Ins / All Channels - I own the Rack Version of NL2X, so another MIDI Keyboard will send notes, Pitch Wheel and ModWheel data to it
‘Monitor': Auto
‘Audio To‘ Master

• Settings on the plugins:
MIDI Track 1 = Program Slot/Layer A
MIDI Track 2 = Program Slot/Layer B
MIDI Track 3 = Program Slot/Layer C
MIDI Track 4 = Program Slot/Layer D

• Settings on 'External Instruments':
MIDI Track 1 = 'MIDI to: Ch.1' - 'Audio from: 1' - ‘Latency: 2ms'
MIDI Track 2 = 'MIDI to: Ch.2' - 'Audio from: 2' - ‘Latency: 2ms'
MIDI Track 3 = 'MIDI to: Ch.3' - 'Audio from: 3' - ‘Latency: 2ms'
MIDI Track 4 = 'MIDI to: Ch.4' - 'Audio from: 4' - ‘Latency: 2ms'

• Settings on the NL2X hardware:
Layer A = MIDI CH 1
Layer B = MIDI CH 2
Layer C = MIDI CH 3
Layer D = MIDI CH 4
Global MIDI CH = G.16
Local = off

Now comes the 'tricky' part: everytime you want to control or change a certain Layer you have to
1) press the Program Slot/Layer on your NL2X Hardware (A,B,C or D)
2) press the TRACK ARM BUTTON in Ableton of the MIDI Track which you want to change (if Layer A, click the Track Arm Button of MIDI Track 1)


If you did everything correctly you are able to play 4 different MIDI clips at the same time, send & receive SysEx for each Layer, make Velocity/Morph settings for each layer, automate/modulate different layers etc. And most important: total recall!


Hope it helps
Cheers
Piet/Protonica

@robse

I guess you are doing it right (almost same procedure here). Ableton does not support SysEx natively so the Bridge is still a compromise solution and causes the majority of your inconvenience with the plugin. :/ Also please keep in mind that you are dealing with a (free) hardware/software solution which even on a Virus TI needs some 'tech love' to make it work nicely... If that's too much and useless you should go with synth plugins instead of hardware.

I usually do a double click on the maxpat file to open the bridge. It's not possible to save the settings, because the sysex bridge will update the available Midi ports on every load. When you open a big live project it can sometimes happen, that the data is not fully sent to the NL on the first load (there are some 'timers' inside the plugin which could cause this problem). So I recommended already in the description to reload the project - 'known bugs'.

Cheers
Piet/Protonica

Since the Firmware update 1.10 introduced note accents (velocity over 100) & note slides (legato notes) you can delete the recorded accent & slide events in Ableton's Envelopes section.
Furthermore when you record Midi clips, Ableton will record all knob movements twice. In the recorded clip you can delete the dublicate events.

Hello LACONIC,

1) please make sure to have TB-3 Firmware 1.10 installed.
2) use Sequencer mode "TB-3" for recording and Sequence mode "Ableton" for playback.
3) Stop the TB-3 sequencer after recording.

@kennycampbell

Yes this might be caused by a feedback loop. To avoid Midi Feedback Loops I added the "sequencer" button. This way it filteres Midi data. If you run a Midi-clip from Ableton to play the TB-3 you have to choose "Ableton" and vice versa.

Piet

@defex
1. Load the preset
2. Change the Patch number
3. Save/overwrite the preset

@defex currently it's not possible to import patches via sysex. I contacted Novation to ask for the sysex midi implementation but without luck. Don't get the politics behind hit... . Anyway there is a workaround by manually input: select a patch which you want to "import" and turn all knobs and submenus. On the bass station you see up and down arrows right from the lcd. When they both are not lighten it shows you the saved value. Hope it helps. (This way I transfered the Factory Patches)

@ pompousjohn no, as far as I know transpositions can not be recorded or transmitted from/to the tb-3 sequencer. as a workaround you could record a pattern into an ableton clip and use the "pitch" midi effect from ableton. or dublicate the clips and transpose it manually.

cool! :)

@ztazz

Some MIDI interfaces/soundcards don't support MULTI CLIENTS on WINDOWS. Please check if you can get a dedicated driver for your interface or try other interfaces from RME, Motu, Steinberg etc.

Cheers
Piet

Great tool, thank you!
Would be nice if the trigger note is saved within the project (I guess its a hidden parameter). Furthermore Pitch- & Modwheel data does not come through.

it's not an universal sysex bridge to use with other synthesizers. but you can use the bridge to receive and send any sysex message. the received messages has to be translated and converted (in an dedicated plugin), which the remote plugin does - in this case for the nord lead 2x. theoriticaly there could be a plugin which receives, saves and sends sysex messages - but actually that shoud be the job of ableton to give us complete control over sysex.

Gabriel, check if you have installed the latest firmware (1.10). So the TB-3 understands "Slides" (overlapping notes/legato). When sequencing with Ableton turn off the Midi-Clock-Sync in the preferences (or use an empty tb-3 pattern).

Tempo sync is not possible with a Nord Lead 2x. Only Key-retrigger which Clavia calls "Sync" which you can find at the "Special" menu on the hardware.

Good point Kibosh!
I just updated it to 1.11. At the moment I don't have Push here but checked on touchAble.
This is how the order looks like:

Page 1:
1. Tuning
2. Cutoff
3. Reso
4. Env Mod
5. Decay
6. Accent
7. Effect 1
8. Effect 2

Page 2:
1. Volume
2. Pitch
3. SC Type
4. Scatter
5. Accents
6. Slide

Hi Apeks,

The MIDI Output Signal from the SysEx Bridge must flash on every dump (Send & Get/Request) you make from the plug-in. Even if a NordLead is not connected.
I build this plug-in for a NordLead 2X which has some minor differences to the NordLead 2. Sending a patch from the Plugin to the NordLead 2 could work.
Receiving a patch from the NordLead 2 (Patch Dump Request) via the plugin could work maybe if you change a code in the plugin: Open the plugin in Max4Live, unfreeze it, go to Patch Mode, find the info box called "Patch Dump Request 14 (Edit Buffer) 0-3 (Slot A-D)", double click on "pack 240 51 15 4 14 0 247" and type in "pack 240 51 15 4 0 0 247", than save it and quit max4live and Ableton. (not sure if it works! just an idea because the MIDI Implementation in the manual from Clavia was incorrect in this case).

In general I only can give the advice to try the plugin with a NordLead 2X only.

Cheers
Piet

Hi Apeks,

The MIDI Output Signal from the SysEx Bridge must flash on every dump (Send & Get/Request) you make from the plug-in. Even if a NordLead is not connected.
I build this plug-in for a NordLead 2X which has some minor differences to the NordLead 2. Sending a patch from the Plugin to the NordLead 2 could work.
Receiving a patch from the NordLead 2 (Patch Dump Request) via the plugin could work maybe if you change a code in the plugin: Open the plugin in Max4Live, unfreeze it, go to Patch Mode, find the info box called "Patch Dump Request 14 (Edit Buffer) 0-3 (Slot A-D)", double click on "pack 240 51 15 4 14 0 247" and type in "pack 240 51 15 4 0 0 247", than save it and quit max4live and Ableton. (not sure if it works! just an idea because the MIDI Implementation in the manual from Clavia was incorrect in this case).

In general I only can give the advice to try the plugin with a NordLead 2X only.

Cheers
Piet

bassmatiker, this is a strange behaviour. it must work with every midi interface (sysex and simple midi at the same time). make sure to connect both midi in and out. also check the midi i/o settings on the ableton preferences.

yes, i even bought the rekon lead editor first. but to be honest the handling for me was not as good as i thought. morphing, mouse behaviour, setup etc. thats why i build this m4l device for the lead2x.

yes, i even bought the rekon lead editor first. but to be honest the handling for me was not as good as i thought. morphing, mouse behaviour, setup etc. thats why i build this m4l device for the lead2x.

@borg thanks for your feedback!
you can scroll through the presets by moving the mouse (left click and hold) over the preset number field. Or type in the desired program number. If u have problems with the program up/down buttons you can try to use "Local on" mode on your synth. this m4l device is tested only for nord lead 2x (which don't uses pcmcia cards anymore)!

@ryancollins yes, as soon as i own one i will do it.

@ Angelique http://www.facebook.com/protonica.de :)

Now you are able to easily scroll through the bank and presets! Check Version 1.2 ;)

I don't have a Nord Lead 1 here to test. I guess most of the parameters should work with a Nord Lead/Rack 1 or 2 too (like Cutoff, Reso...). But when it comes to waveform selection, lfo destination etc. it can work different. Anyway i can easily make another device for Nord Lead 1 for sure, but would need a kind of bug report to see what i need to change.